Home Forums Kadence Theme Fatal Error since Kadence Blocks 2.0.1

This topic is: resolved
Resolved
Posted in: Kadence Theme  
  • May 4, 2021 at 2:29 am #265534

    Hi Ben,

    Im using PHP 8.0.3 on one of my dev sites. All Plugins and Kadence Theme up to date.

    On this sites I got a fatal error when I visit one page of the site:

    Ein Fehler vom Typ E_ERROR wurde in der Zeile 3249 der Datei /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-content/plugins/kadence-blocks/dist/class-kadence-blocks-frontend.php verursacht. Fehlermeldung: Uncaught Error: Object of class Kadence_Blocks_CSS could not be converted to string in /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-content/plugins/kadence-blocks/dist/class-kadence-blocks-frontend.php:3249
    Stack trace:
    #0 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-content/plugins/kadence-blocks/dist/class-kadence-blocks-frontend.php(769): Kadence_Blocks_Frontend->blocks_infobox_array()
    #1 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/class-wp-block.php(221): Kadence_Blocks_Frontend->render_infobox_css()
    #2 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/class-wp-block.php(211): WP_Block->render()
    #3 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/class-wp-block.php(211): WP_Block->render()
    #4 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/blocks.php(799): WP_Block->render()
    #5 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/blocks.php(837): render_block()
    #6 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/class-wp-hook.php(292): do_blocks()
    #7 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/plugin.php(212): WP_Hook->apply_filters()
    #8 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php(1768): apply_filters()
    #9 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php(550): WP_REST_Posts_Controller->prepare_item_for_response()
    #10 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/rest-api/class-wp-rest-server.php(1139): WP_REST_Posts_Controller->get_item()
    #11 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/rest-api/class-wp-rest-server.php(985): WP_REST_Server->respond_to_request()
    #12 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/rest-api.php(479): WP_REST_Server->dispatch()
    #13 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-includes/rest-api.php(2816): rest_do_request()
    #14 [internal function]: rest_preload_api_request()
    #15 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-admin/edit-form-blocks.php(82): array_reduce()
    #16 /var/www/vhosts/domain.tld/devdevdev.domain.tld/wp-admin/post.php(187): require('...')
    #17 {main}
    thrown

    When I downgrade to 1.10.9. it is wokring again. Sorry I see I choose the fron forum…

    Thank you for your awesome work :)!

    Tobias

    • This topic was modified 2 days, 21 hours ago by Netzlichter. Reason: When I downgrade to 1.10.9. it is wokring again. Sorry I see I choose the fron forum

    Please Login to continue

    If you do not have an account you can register here.